Troubleshooting Guide

We are aware of an issue stopping DocuGen integrations created prior to the 13 November 2020 release. Check out the easy fix here.

Please check if your issue can be fixed by any of the workarounds below. If you are still facing issues, you can chat real-time with our agents on this website or in-app within DocuGen. You can also submit a ticket using the form at the bottom of this page.

Are you using monday.com in Hebrew, Japanese, Chinese, or Korean?

We are aware of an issue with some languages: DocuGen Settings allow you to select which columns will appear in your document, but if your monday.com user interface is set in one of the above languages, DocuGen may be unable to apply your column selection properly: it may display all columns or no columns. We are working with monday.com to resolve this issue.

Workaround: When you create your board or whenever you add new columns to your board, make sure you are on the English interface. Once you are done adding columns, you can switch back to your original language, and you can rename your column labels in any language.

I added DocuGen view to the board, but it keeps loading indefinitely

Please check the following:

  1. Make sure your browser is not in incognito mode
  2. Make sure you have not disabled cross-site (third-party) cookies in your browser security settings. Here are the instructions for Google Chrome and the instructions for Safari.

If you’re still facing issues, it may be that Google revoked your Google connection to DocuGen. If you use another browser, it should work fine. Please drop us a word using the form at the bottom of this page and we will manually reset your connection from the back-end.

The “Generate document” button is disabled

If the “Generate document” button appears disabled (not clickable), check that your monday.com board is not empty (it should have at least one row), then refresh your page and check again.

Still no luck? Drop us a word using the form at the bottom of this page.

DocuGen keeps asking me to “Sign in with Google”

DocuGen should ask you to sign in with Google only once the first time you add it as a view to a board. If DocuGen keeps asking you to sign in with Google, your browser is probably blocking third-party cookies or you are using DocuGen in incognito mode:

  1. Make sure your browser is not in incognito mode
  2. Make sure you have not disabled cross-site (third-party) cookies in your browser security settings. Here are the instructions for Google Chrome and the instructions for Safari.

If you’re still facing issues, it may be that Google revoked your Google connection to DocuGen. If you use another browser, it should work fine. Please drop us a word using the form at the bottom of this page and we will manually reset your connection from the back-end.

When I click “Generate document”, the waiting icon keeps spinning indefinitely

Please verify the following:

1. Generating documents from a large board may take a long time or fail altogether. Make sure to apply a filter to your board before generating a document containing a large number of rows. It also helps to reduce the number of output formats to one or two.

2. If you have specified a template in your DocuGen Settings, make sure the Google Doc template is still available and has not been deleted.

3. If you are not the owner of the Google Doc template, make sure you have “copy” sharing right on the Google Doc template: ask the owner to make sure the document’s sharing settings have the following setting selected: “Viewers and commenters can see the option to download, print, and copy”:

Still no luck? Drop us a word using the form at the bottom of this page.

When I click on a button in a button column, documents are not generated

Documents generated by clicking a button column may not automatically appear immediately in the Documents tab. Wait a few seconds after clicking the button and refresh the DocuGen view in order for the newly-generated documents to appear in the list. (We are working on fixing this.)

The DocuGen Settings tab is not loading; the waiting icon keeps spinning indefinitely

If your DocuGen view loads fine, but the Settings tab doesn’t, refresh the web page (from the browser) and try again.

DocuGen integrations give an error message {“message”: “Internal server error”}

This error message means you have not yet added DocuGen as a view on the board. You must add DocuGen view on every board where you intend to use DocuGen integrations.

Document consumption information in the Statistics tab is not accurate

Please read the Statistics tab article to understand what the numbers represent.

Column styling in the Settings tab does not appear correctly in the generated documents

Column styling options in the Settings tab apply in two cases only:

  1. When generating a document without using a template
  2. When using the <<table_start>> placeholder in a template.

If you wish to style text that is inserted using any other placeholder (such as <<board_name>>, <<user_name>>, <<column_firstrow:XXX>>, etc.), you can simply apply the desired styling directly on the placeholder within the template being used by DocuGen.

Still no luck? Submit a ticket and we will get back to you

Leave a Reply